Creating Your First Gem

Submitted by Christoph Olszowka 2011-10-13 15:21:10 UTC
Source:  http://rubysource.com/creating-your-first-gem/

Referenced projects

Rubygems

RubyGems is a package management framework for Ruby. This gem is an update for the RubyGems software. You must have an installation of RubyGems before this update can be applied. See Gem for information on RubyGems (or `ri Gem`) To upgrade to the latest RubyGems, run: $ gem update --system # you might need to be an administrator or root See UPGRADING.rdoc for more details and alternative instructions. ----- If you don't have RubyGems installed, you can still do it manually: * Download from: https://rubygems.org/pages/download * Unpack into a directory and cd there * Install with: ruby setup.rb # you may need admin/root privilege For more details and other options, see: ruby setup.rb --help

Rubygem rubygems-update

Total Downloads
5970678
Releases
106
Current Version
2.2.2
Released
2014-02-05 00:00:00 UTC
First Release
2004-12-07 05:00:00 UTC
Depends on following gems
Depending Gems
6
×

In order to continue, you must be signed in using your Github account.

If you're signing in using this account for the first time Github will ask for your permission to give access to your public user data to the Ruby Toolbox.

Although the Github Authorization page does not mention it, the request includes read-only access to your verified email address (user:email OAuth scope). This is neccessary so there's a way to notify you about comments, information about your accepted project edits and the like. You can review your notification settings on your account page once you're signed in.