Deprecation Tools

Deprecated

An easy way to handle deprecating and conditionally running deprecated code

Rubygem deprecated

Total Downloads
296307
Releases
5
Current Version
3.0.1
Released
2012-09-29 00:00:00 UTC
First Release
2006-02-15 08:00:00 UTC
Depends on following gems
Depending Gems
6

Github erikh/deprecated

Watchers
7
Forks
1
Development activity
Inactive
Last commit
2012-09-29 05:44:59 UTC
Top contributors
Contributors
2
Issues

Structured Warnings

This is an implementation of Daniel Berger's proposal of structured warnings for Ruby.

Rubygem structured_warnings

Total Downloads
110190
Releases
5
Current Version
0.1.4
Released
2013-04-26 00:00:00 UTC
First Release
2008-02-20 23:00:00 UTC
Depends on following gems
Depending Gems
5

Github schmidt/structured_warnings

Watchers
7
Forks
1
Development activity
Inactive
Last commit
2013-05-23 19:14:27 UTC
Top contributors
Contributors
3
Issues
×

In order to continue, you must be signed in using your Github account.

If you're signing in using this account for the first time Github will ask for your permission to give access to your public user data to the Ruby Toolbox.

Although the Github Authorization page does not mention it, the request includes read-only access to your verified email address (user:email OAuth scope). This is neccessary so there's a way to notify you about comments, information about your accepted project edits and the like. You can review your notification settings on your account page once you're signed in.