The project is in a healthy, maintained state
Learn enough
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
 Project Readme

Palindrome detector

mhartl_palindrome is a sample Ruby gem created in Learn Enough Ruby to Be Dangerous by Michael Hartl.

Installation

To install mhartl_palindrome, add this line to your application's Gemfile:

gem 'mhartl_palindrome'

Then install as follows:

$ bundle install

Or install it directly using gem:

$ gem install mhartl_palindrome

Usage

mhartl_palindrome adds a palindrome? method to the String class, and can be used as follows:

$ irb
>> require 'mhartl_palindrome'
>> "honey badger".palindrome?
=> false
>> "deified".palindrome?
=> true
>> "Able was I, ere I saw Elba.".palindrome?
=> true
>> phrase = "Madam, I'm Adam."
>> phrase.palindrome?
=> true

License

The gem is available as open source under the terms of the MIT License.