0.09
No release in over a year
For use for the Beaker acceptance testing tool
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
2021
2022
 Dependencies

Development

~> 0.10
~> 3.0
>= 0
>= 0
>= 0.6, < 2.0
~> 13.0
 Project Readme

beaker-vagrant

Beaker library to use vagrant hypervisor

How to use this wizardry

This is a gem that allows you to use hosts with vagrant hypervisor with beaker.

With Beaker 3.x

This library is included as a dependency of Beaker 3.x versions, so there's nothing to do.

With Beaker 4.x

As of Beaker 4.0, all hypervisor and DSL extension libraries have been removed and are no longer dependencies. In order to use a specific hypervisor or DSL extension library in your project, you will need to include them alongside Beaker in your Gemfile or project.gemspec. E.g.

# Gemfile
gem 'beaker', '~>4.0'
gem 'beaker-vagrant'
# project.gemspec
s.add_runtime_dependency 'beaker', '~>4.0'
s.add_runtime_dependency 'beaker-vagrant'

Spec tests

Spec test live under the spec folder. There are the default rake task and therefore can run with a simple command:

bundle exec rake test:spec

Acceptance tests

We run beaker's base acceptance tests with this library to see if the hypervisor is working with beaker. There is a simple rake task to invoke acceptance test for the library:

bundle exec rake test:acceptance

Contributing

Please refer to puppetlabs/beaker's contributing guide.

Release

To release new versions, we use a Jenkins job (access to internal infrastructure will be required to view job).

To release a new version (from the master branch), you'll need to just provide a new beaker-pe version number to the job, and you're off to the races.