Project

bs5

0.0
The project is in a healthy, maintained state
[WIP] Rails engine to include Bootstrap 5.
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
 Project Readme

Bs5

This is a Ruby on Rails engine to include Bootstrap 5.

Gem Version

Usage

How to use my plugin.

Installation

Add this line to your application's Gemfile:

gem 'bs5'

And then execute:

$ bundle

Or install it yourself as:

$ gem install bs5

Configuration

Run the following command to setup your project to use Bootstrap 5.

$ rails generate bs5:install

Components

Alert 🖌

<%= render Bs5::AlertComponent.new do %>
  A simple primary alert—check it out!
<%- end %>
<%= render Bs5::AlertComponent.new(type: :warning, is_dismissable: true) do %>
  <strong>Holy guacamole!</strong> You should check in on some of those fields below.
<%- end %>

Previewing components

Contributing

Contribution directions go here.

License

The gem is available as open source under the terms of the MIT License.