Project

dry-cli

0.17
No release in over a year
Common framework to build command line interfaces with Ruby
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
2021
2022
 Dependencies

Development

>= 1.6, < 3
~> 13.0
~> 3.7
~> 0.17.1
~> 0.82
 Project Readme

dry-cli Join the chat at https://dry-rb.zulipchat.com

Gem Version CI Status Codacy Badge Codacy Badge Inline docs

Links

Supported Ruby versions

This library officially supports the following Ruby versions:

  • MRI >= 2.4.0
  • jruby >= 9.3 (postponed until 2.7 is supported)

License

See LICENSE file.