The project is in a healthy, maintained state
google-cloud-errors defines error classes for google-cloud-ruby.
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
 Project Readme

Google Cloud Ruby Client

Idiomatic Ruby client for Google Cloud Platform services.

Coverage Status Gem Version

This client supports the following Google Cloud Platform services:

  • Cloud Asset
  • Cloud AutoML API
  • BigQuery
  • BigQuery Data Transfer Service
  • Cloud Bigtable
  • Cloud Billing API
  • Container Analysis
  • Container Engine
  • Data Loss Prevention
  • Cloud Dataproc
  • Cloud Datastore
  • Cloud Debugger
  • Dialogflow API
  • Cloud DNS
  • Cloud Error Reporting
  • Cloud Firestore
  • Cloud Key Management Service
  • Cloud Natural Language API
  • Cloud Logging
  • Cloud Monitoring
  • Cloud OS Login
  • Phishing Protection
  • Cloud Pub/Sub
  • Recaptcha Enterprise
  • Recommender
  • Cloud Redis
  • Cloud Resource Manager
  • Cloud Scheduler
  • Secret Manager
  • Cloud Security Center
  • Cloud Spanner
  • Cloud Speech-to-Text
  • Cloud Storage
  • Cloud Talent Solution
  • Cloud Tasks
  • Cloud Text-To-Speech
  • Cloud Trace
  • Cloud Translation API
  • Video Intelligence API
  • Cloud Vision API
  • Web Risk API

The support for each service is distributed as a separate gem.

Authentication

In general, the google-cloud-ruby library uses Service Account credentials to connect to Google Cloud services. When running on Google Cloud Platform (GCP), including Google Compute Engine (GCE), Google Kubernetes Engine (GKE), Google App Engine (GAE), Google Cloud Functions (GCF) and Cloud Run, the credentials will be discovered automatically. When running on other environments, the Service Account credentials can be specified by providing the path to the JSON keyfile for the account (or the JSON itself) in environment variables. Additionally, Cloud SDK credentials can also be discovered automatically, but this is only recommended during development.

Specific instructions and environment variables for each individual service are linked from the README documents listed below for each service.

Cloud Asset

Cloud AutoML API

BigQuery

BigQuery Data Transfer Service

Cloud Bigtable

Cloud Billing API

Container Analysis

Container Engine

Data Loss Prevention

Cloud Dataproc

Cloud Datastore

Cloud Debugger

Dialogflow API

Cloud DNS

Cloud Error Reporting

Cloud Firestore

Cloud Key Management Service

Cloud Natural Language API

Cloud Logging

Cloud Monitoring

Cloud OS Login

Phishing Protection

Cloud Pub/Sub

Recaptcha Enterprise

Recommender

Cloud Redis

Cloud Resource Manager

Cloud Scheduler

Secret Manager

Cloud Security Center

Cloud Spanner

Cloud Speech-to-Text

Cloud Storage

Cloud Talent Solution

Cloud Tasks

Cloud Text-to-Speech

Cloud Trace

Cloud Translation API

Video Intelligence API

Cloud Vision API

Web Risk API

Supported Ruby Versions

These libraries are currently supported on Ruby 2.4+.

Google provides official support for Ruby versions that are actively supported by Ruby Core—that is, Ruby versions that are either in normal maintenance or in security maintenance, and not end of life. Currently, this means Ruby 2.4 and later. Older versions of Ruby may still work, but are unsupported and not recommended. See https://www.ruby-lang.org/en/downloads/branches/ for details about the Ruby support schedule.

Library Versioning

The libraries in this repository follow Semantic Versioning.

Note that different libraries may be released at different support quality levels:

GA: Libraries defined at the GA (general availability) quality level, indicated by a version number greater than or equal to 1.0, are stable. The code surface will not change in backwards-incompatible ways unless absolutely necessary (e.g. because of critical security issues), or unless accompanying a semver-major version update (such as version 1.x to 2.x.) Issues and requests against GA libraries are addressed with the highest priority.

Beta: Libraries defined at a Beta quality level, indicated by a version number less than 1.0, are expected to be mostly stable and we're working towards their release candidate. However, these libraries may get backwards-incompatible updates from time to time. We will still address issues and requests with a high priority.

Contributing

Contributions to this library are always welcome and highly encouraged.

See CONTRIBUTING for more information on how to get started.

Please note that this project is released with a Contributor Code of Conduct. By participating in this project you agree to abide by its terms. See Code of Conduct for more information.

License

This library is licensed under Apache 2.0. Full license text is available in LICENSE.

Support

Please report bugs at the project on Github. Don't hesitate to ask questions about the client or APIs on StackOverflow.