Low commit activity in last 3 years
A long-lived project that still receives updates
Guard::Bundler automatically install/update your gem bundle when needed
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
 Project Readme

Guard::Bundler

Gem Version Build Status Code Climate Coverage Status

Bundler guard allows to automatically & intelligently install/update bundle when needed.

  • Compatible with Bundler 2.1.x
  • Tested against the latest Ruby 2.4.x, 2.5.x, 2.6.x, JRuby & Rubinius. See .travis-ci.yml for the exact versions.

Install

Add the gem to your Gemfile:

group :development do
  gem 'guard-bundler', require: false
end

Add the plugin definition to your Guardfile by running this command:

$ guard init bundler

Usage

Please read the Guard usage doc

Guardfile

Guard::Bundler plugin can be really adapted to all kind of projects.

You can tweak the default Guardfile template (created by guard init bundler) if you need to watch files other than the Gemfile or *.gemspec (or if they are in different paths).

Please read the Guard usage doc for more information about the Guardfile DSL.

Development

Pull requests are very welcome! Please try to follow these simple rules if applicable:

  • Please create a topic branch for every separate change you make.
  • Update the README.
  • Please do not change the version number.

For questions please join us in our Google group or on #guard (irc.freenode.net).

Author

Yann Lugrin

Maintainer

Rémy Coutable (@rymai)

Contributors

https://github.com/guard/guard-bundler/graphs/contributors