Project

numpy

0.01
The project is in a healthy, maintained state
Numpy wrapper for Ruby
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
2021
2022
 Dependencies

Development

Runtime

>= 1.2.0.beta1
 Project Readme

Numpy wrapper for Ruby

This library enables to directry call numpy from Ruby language. This uses pycall.

Installation

Add this line to your application's Gemfile:

gem 'numpy'

And then execute:

$ bundle

Or install it yourself as:

$ gem install numpy

Usage

Example usage:

require 'numpy'

x = Numpy.asarray([[1, 2, 3], [4, 5, 6]])
puts x
# [[1 2 3]
#  [4 5 6]]

puts x[1, 1..2]
# [5 6]

puts x.T
# [[1 4]
#  [2 5]
#  [3 6]]

puts x.dot x.T
# [[14 32]
#  [32 77]]

puts x.reshape([3, 2])
# [[1 2]
#  [3 4]
#  [5 6]]

Development

After checking out the repo, run bin/setup to install dependencies. Then, run rake spec to run the tests. You can also run bin/console for an interactive prompt that will allow you to experiment.

To install this gem onto your local machine, run bundle exec rake install. To release a new version, update the version number in version.rb, and then run bundle exec rake release, which will create a git tag for the version, push git commits and tags, and push the .gem file to rubygems.org.

Contributing

Bug reports and pull requests are welcome on GitHub at https://github.com/mrkn/numpy.

License

The gem is available as open source under the terms of the MIT License.