No commit activity in last 3 years
No release in over 3 years
Polychoric and Tetrachoric extensions for Statsample::Bivariate.
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
2021
 Dependencies

Development

~> 1.10
~> 0.1
~> 10.4
~> 1.16
>= 0

Runtime

~> 0.1
 Project Readme

statsample-bivariate-extension

Build Status

DESCRIPTION:

Provides advanced bivariate statistics:

  • Tetrachoric correlation
  • Polychoric correlation

FEATURES/PROBLEMS:

  • Statsample::Bivariate::Polychoric class provides polychoric correlation
  • Statsample::Bivariate::Tetrachoric class provides tetrachoric correlation

SYNOPSIS:

Tetrachoric correlation

require 'statsample'
a=40
b=10
c=20
d=30
tetra=Statsample::Bivariate::Tetrachoric.new(a,b,c,d)
puts tetra.summary

Polychoric correlation

require 'statsample'
ct=Matrix[[58,52,1],[26,58,3],[8,12,9]]

poly=Statsample::Bivariate::Polychoric.new(ct)
puts poly.summary

REQUIREMENTS:

  • Statsample

INSTALL:

This gem is a statsample dependency. If you want to install it separatly

  • gem install statsample-bivariate-extension

LICENSE:

BSD 2-Clause (see LICENSE.txt)