No commit activity in last 3 years
No release in over 3 years
There's a lot of open issues
This gem integrates the Twitter Bootstrap pagination component with the will_paginate pagination gem. Supports Rails and Sinatra.
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
2021
2022
 Dependencies

Runtime

 Project Readme

will_paginate-bootstrap


No longer maintained

I'm no longer using Bootstrap with Rails, so unfortunately am no longer accepting pull requests or maintaining this library. Feel free to fork this repository in order to publish your changes, or get in touch with me if you'd like to take over maintenance of the gem.


Code Climate

Bootstrap Pagination Component

This gem integrates the Twitter Bootstrap pagination component with the will_paginate pagination gem.

Just like will_paginate, Rails and Sinatra are supported.

Install

  • gem install will_paginate-bootstrap, or
  • For projects using Bundler, add gem 'will_paginate-bootstrap' to your Gemfile (and then run bundle install).

Usage

Rails

  1. Load the Bootstrap CSS in your template.
  2. In your view, use the renderer: BootstrapPagination::Rails option with the will_paginate helper, for example:
<%= will_paginate @collection, renderer: BootstrapPagination::Rails %>

Sinatra

  1. Load the Bootstrap CSS in your template.
  2. require "will_paginate-bootstrap" in your Sinatra app.
  3. In your view, use the renderer: BootstrapPagination::Sinatra option with the will_paginate helper, for example:
<%= will_paginate @collection, renderer: BootstrapPagination::Sinatra %>

Compatibility

Starting at version 1.0, this gem no longer supports Bootstrap 2.

Ruby >= 1.9.2
will_paginate >= 3.0.3
Twitter Bootstrap >= 3.0.0

Bootstrap 2 users can use version 0.2.5 of the gem which was the last version to offer Bootstrap 2 support.