Project

zabbixapi

0.27
No release in over a year
Allows you to work with zabbix api from ruby.
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
2021
2022
2023
 Dependencies

Development

Runtime

~> 2.0
~> 2.0
 Project Readme

Ruby Zabbix Api Module

Gem Version Build Status

Simple and lightweight ruby module for working with Zabbix via the Zabbix API

Installation

# latest
gem install zabbixapi

# specific version
gem install zabbixapi -v 4.2.0

Documentation

http://rdoc.info/gems/zabbixapi

Examples

https://github.com/express42/zabbixapi/tree/master/examples

Version Policy

NOTE: master branch is used for ongoing development on Zabbix API 5.x (5.0 and 5.2).

We support only two last versions of zabbix (5.0 and 5.2), so you should consider all previous versions deprecated.

Supported Ruby Versions

This library aims to support and is tested against the following Ruby versions:

  • Ruby 2.5
  • Ruby 2.6
  • Ruby 2.7
  • JRuby 9.2.10.0

If something doesn't work on one of these versions, it's a bug.

This library may inadvertently work (or seem to work) on other Ruby versions, however support will only be provided for the versions listed above.

If you would like this library to support another Ruby version or implementation, you may volunteer to be a maintainer. Being a maintainer entails making sure all tests run and pass on that implementation. When something breaks on your implementation, you will be responsible for providing patches in a timely fashion. If critical issues for a particular implementation exist at the time of a major release, support for that Ruby version may be dropped.

Dependencies

  • net/http
  • json

Contributing

  • Fork the project.
  • Base your work on the master branch.
  • Make your feature addition or bug fix, write tests, write documentation/examples.
  • Commit, do not mess with rakefile, version.
  • Make a pull request.

Zabbix documentation

Copyright

See LICENSE for details.