0.0
There's a lot of open issues
Hitch lets MCP clients -- Claude, ChatGPT, Cursor -- call your Rails app's tools as a specific signed-in user, with access you can revoke. You do not stand up a separate auth server, add Redis, or adopt a new sign-in system. Hitch uses the authentication your app already has (current_user or Cur...
2021
2022
2023
2024
2025
2026
0.0
The project is in a healthy, maintained state
clickwrap turns Terms acceptance, privacy notice acknowledgments, consent, declarations, attestations, and one-time authorizations into one Rails primitive: frozen document versions, server-owned policies, atomic evidence capture (the evidence and the protected action commit in the same transacti...
2021
2022
2023
2024
2025
2026
0.0
No commit activity in last 3 years
No release in over 3 years
Bali (Bulwark Authorization Library) is a to-the-point authorization library for Rails.
2021
2022
2023
2024
2025
2026
0.0
No release in over a year
CCCUX provides a comprehensive admin interface and user experience layer for CanCanCan authorization. It includes role-based access control (RBAC) models, admin controllers for managing users, roles, and permissions, and a clean interface for authorization management.
2021
2022
2023
2024
2025
2026
0.0
Repository is gone
No release in over 3 years
A fork of Steffen Bartsch’s declarative_authorization equipped with localization based on Rails default I18n.
2021
2022
2023
2024
2025
2026
0.0
No commit activity in last 3 years
No release in over 3 years
Provides a simple DSL for specifying the authorization logic of your application. Install the gem, add a role attribute to your user model and your almost ready to go.
2021
2022
2023
2024
2025
2026
0.0
No release in over 3 years
Rails authorization for well defined authorization objects interfaces
2021
2022
2023
2024
2025
2026
0.0
No commit activity in last 3 years
No release in over 3 years
The Tripletex API is a **RESTful API**, which does not implement PATCH, but uses a PUT with optional fields. **Actions** or commands are represented in our RESTful path with a prefixed `:`. Example: `/v2/hours/123/:approve`. **Summaries** or aggregated results are represented in our RESTful pat...
2021
2022
2023
2024
2025
2026
0.0
Low commit activity in last 3 years
A long-lived project that still receives updates
This Sinatra extension, derived from omniauth_pure by Marcus Proske, adds OmniAuth authorization to your Sinatra application, so your users can login using FaceBook, Twitter and many other authorization providers, as long as you supply the API keys. It uses DataMapper and HAML.
2021
2022
2023
2024
2025
2026
0.0
A long-lived project that still receives updates
Permify is an open source authorization service for creating fine-grained and scalable authorization systems.
2021
2022
2023
2024
2025
2026
0.0
No commit activity in last 3 years
No release in over 3 years
A neat way of asserting declarative_authorization's rules inside controller using RSpec matcher.
2021
2022
2023
2024
2025
2026
0.0
No commit activity in last 3 years
No release in over 3 years
Simple authorization for RubyMotion. Inspired by CanCan and Pundit.
2021
2022
2023
2024
2025
2026
0.0
No commit activity in last 3 years
No release in over 3 years
This generator can add powerful authentication and authorization to a clean Rails application with a single command. Configures a Rails application for use with the authlogic and declarative_authorization gems, and generates all code (migrations, models, controller methods, routes, roles, seeds,...
2021
2022
2023
2024
2025
2026
0.0
No commit activity in last 3 years
No release in over 3 years
An(other) Rails authorization solution which allows an app to aggregate and arbitrate authorization for permissions from multiple roles and multiple products (permissifed models).
2021
2022
2023
2024
2025
2026
0.0
Repository is gone
No release in over 3 years
Rails 3 compatible rails-authorization-plugin gem
2021
2022
2023
2024
2025
2026
0.0
No commit activity in last 3 years
No release in over 3 years
Pundit is a lightweight authorization gem. But, in complex Rails apps, it can be difficult to determine why authorization failed, or which policies are involved in a request. pundit_logger adds logging during many Pundit events to your Rails application logs.
2021
2022
2023
2024
2025
2026
0.0
The project is in a healthy, maintained state
Token exchange (RFC 8693), client credentials, authorization code + PKCE, dynamic client registration (RFC 7591), authorization server discovery (RFC 8414), UserInfo, JWT/JWKS verification, application credentials, and the AccessContext delegated-access container.
2021
2022
2023
2024
2025
2026