Project

libhoney

0.15
A long-lived project that still receives updates
Ruby gem for sending data to Honeycomb
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
2021
2022
 Dependencies

Development

~> 0.5
~> 5.0
~> 13.0
= 1.12.1
~> 1.0
~> 3.4
>= 0
~> 0.9

Runtime

>= 0
>= 2.0, < 6.0
 Project Readme

libhoney

OSS Lifecycle CircleCI Build Status Gem Version

Ruby gem for sending events to Honeycomb, a service for debugging your software in production.

Requires Ruby 2.3 or greater.

For tracing support and automatic instrumentation of Rails, Sinatra, Rack, ActiveRecord, and other frameworks, check out our Beeline for Ruby.

Contributions

Features, bug fixes and other changes to libhoney are gladly accepted. Please open issues or a pull request with your change. Remember to add your name to the CONTRIBUTORS file!

All contributions will be released under the Apache License 2.0.