No release in over 3 years
Low commit activity in last 3 years
Ruby wrapper for the LinkedIn API
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
2021
2022
 Dependencies

Development

~> 10
~> 2.13
~> 0.7
~> 2.5
~> 1.11
>= 0

Runtime

~> 3.0
~> 1.0
 Project Readme

LinkedIn

Ruby wrapper for the LinkedIn API. The LinkedIn gem provides an easy-to-use wrapper for LinkedIn's REST APIs.

Travis CI : Build Status

Installation

gem install linkedin

Documentation

http://rdoc.info/gems/linkedin

Usage

View the Examples

Changelog

View the Changelog

TODO

  • Update and correct test suite
  • Change to Faraday for authentication
  • Implement Messaging APIs

Note on Patches/Pull Requests

  • Fork the project.
  • Make your feature addition or bug fix.
  • Add tests for it. This is important so I don't break it in a future version unintentionally.
  • Make sure your test doesn't just check of instance of LinkedIn::Mash 😄.
  • Commit, do not mess with rakefile, version, or history. (if you want to have your own version, that is fine but bump version in a commit by itself I can ignore when I pull)
  • Send me a pull request. Bonus points for topic branches.

Copyright

Copyright (c) 2013-Present Matt Kirk 2009-11 Wynn Netherland. See LICENSE for details.