No release in over a year
ValidatesTimeliness mongoid ORM compatability.
2005
2006
2007
2008
2009
2010
2011
2012
2013
2014
2015
2016
2017
2018
2019
2020
2021
2022
 Dependencies

Development

~> 2.2, <= 2.2.16
~> 2.17
~> 13.0, >= 13.0.3
~> 6.0.4
~> 3.10
~> 1.13.0
~> 1.11, >= 1.11.1
~> 0.21.2

Runtime

~> 7.2, >= 7.2.2
 Project Readme

ValidatesTimeliness::Mongoid

RSpec Linter Gem Version Docs Maintainability Test Coverage Known Vulnerabilities

This the extracted mongoid adapter code from the validates_timeliness gem.

Installation

Add this line to your application's Gemfile:

gem 'validates_timeliness-mongoid'

And then execute:

$ bundle

Or install it yourself as:

$ gem install validates_timeliness-mongoid

Development

After checking out the repo, run bin/setup to install dependencies. Then, run rake false to run the tests. You can also run bin/console for an interactive prompt that will allow you to experiment.

To install this gem onto your local machine, run bundle exec rake install. To release a new version, update the version number in version.rb, and then run bundle exec rake release, which will create a git tag for the version, push git commits and tags, and push the .gem file to rubygems.org.

Contributing

Bug reports and pull requests are welcome on GitHub at https://github.com/adzpa/validates_timeliness-mongoid.