0.4
Rodauth is Ruby's most advanced authentication framework, designed
to work in all rack applications. It's built using Roda and Sequel,
but it can be used as middleware in front of web applications that use
other web frameworks and database libraries.
Rodauth aims to provide strong security for ...
2021
2022
2023
2024
2025
2026
0.7
WebAuthn ruby server library ― Make your application a W3C Web Authentication conformant
Relying Party and allow your users to authenticate with FIDO2/U2F authenticators as passkeys or security keys.
2021
2022
2023
2024
2025
2026
0.47
Simple (but safe) token authentication for Rails apps or API with Devise.
2021
2022
2023
2024
2025
2026
0.59
Ruby/NTLM HTTP provides NTLM authentication over http.
2021
2022
2023
2024
2025
2026
0.56
An implementation of RFC 2617 - Digest Access Authentication. At this time
the gem does not drop in to Net::HTTP and can be used for with other HTTP
clients.
In order to use net-http-digest_auth you'll need to perform some request
wrangling on your own. See the class documentation at Net::HTTP...
2021
2022
2023
2024
2025
2026
0.55
This module provides common interface to HMAC functionality. HMAC is a kind of "Message Authentication Code" (MAC) algorithm whose standard is documented in RFC2104. Namely, a MAC provides a way to check the integrity of information transmitted over or stored in an unreliable medium, based on a s...
2021
2022
2023
2024
2025
2026
0.37
Mixes in simple per-request authentication
2021
2022
2023
2024
2025
2026
0.52
OAuth 2 authentication with the Azure ActiveDirectory V2 API.
2021
2022
2023
2024
2025
2026
0.52
Authentication solution for Rails based on JWT
2021
2022
2023
2024
2025
2026
0.52
A collection of useful Rails generator scripts for scaffolding, layout files, authentication, and more.
2021
2022
2023
2024
2025
2026
0.52
Simple key/secret based authentication for apis
2021
2022
2023
2024
2025
2026
0.0
Provide a Rails authentication active model.
2021
2022
2023
2024
2025
2026
0.0
Generates a pre-built, security-conscious authentication system into a Rails app: DB-backed sessions with idle/absolute timeouts, paranoid flows, magic links, TOTP MFA, an admin area, and more, all opt-in via flags. Inspired by authentication-zero.
2021
2022
2023
2024
2025
2026
0.0
Provides authentication related stuff.
2021
2022
2023
2024
2025
2026
0.0
A thin wrapper around the Rails `flash' object to assist in redirecting the user `back' after authentication.
2021
2022
2023
2024
2025
2026
0.5
Simple Authentication and Security Layer (RFC 4422)
2021
2022
2023
2024
2025
2026
0.49
Provides common authentication needs such as signing in/out, activating by email and resetting password.
2021
2022
2023
2024
2025
2026
0.48
JWT authentication for devise with configurable token revocation strategies
2021
2022
2023
2024
2025
2026
0.32
### Features ###
* control sms code pattern
* configure max login attempts
* per user level control if he really need two factor authentication
* your own sms logic
2021
2022
2023
2024
2025
2026
0.01
Authsignal is a passwordless authentication/multifactor authentication with modern factors like passkeys
2021
2022
2023
2024
2025
2026